Back to overview
Maintenance

Update maintenance

Jan 28, 2026 at 10:00pm UTC  –  Jan 29, 2026 at 12:00am UTC
Affected services
titan.tamhost.cz

Resolved
Jan 28, 2026 at 10:00pm UTC

Updating node